Xperia X: No more network after update to 4.4.0.68

After updating to 4.4.0.68 I do not have any network-coverage at all. No Mobile Network, no WLAN, no 4G, no anything. The symbol on upper right corner shows a greyish “no network”-symbol (diagonally dashed square). no possibility to turn on WLAN etc. Edit: Also the Phone-App is not working. All other Apps seem to work.
Obviously turned off and on several times, tried to clean SIM (works well in other device) and did not find any help here in the forum up to now.

My phone worked pretty well before updating, apart the known 4G issue that appeared more often in the last weeks.

I’m a long-time Jolla / Sailfish-User, using Terminal every now and then but still rather a DAU. :man_shrugging:

Thanks for helping. And sorry, if the Topic is in the wrong section. Feel free to move it.

Staying on 4.4.0.58 until further notice - at least BT activation/deactivation works now :slight_smile:

Thats not really helping. First I don’t know the Version I was on before, but I think it was a 4.3.0… Second I don’t know how to downgrade (and I think I remember that you never should do so?)

Something happened between 4.4.0.64 and 4.4.0.68 , but from …58 to 64 went fine on both Xperia 10 and Volla. …68 also works fine on the Xperia 10, but not on Volla.
Fortunately the step back from 68 to 64 succeeded on the Volla, so I’m fine at the moment.

@DrDweeb I think update to 64 is low risk, 68 I don’t know. What device do you use?

@Knypser Maybe you want to try as devel-su:

devel-su
ssu release 4.4.0.64
zypper ref
zypper dup

this way I got my crashed Volla back working at that time.

edit: silly me, the above written works only if you bring at least one network access to work…

I have an X with 4.4.0.58 which works mostly fine. There is a problem re-activating mobile data after using WAN/hotspot. I haven’t sat down to bug this yet.

I have an 10iii with 4.4.0.68 which I have been testing which has a BT issue with my car :frowning: that my X doesn’t. I haven’t tested it with mobile data.

@DrDweeb There is a problem re-activating mobile data after using WAN/hotspot…

my workaround is to switch off WLAN manually before activating mobile data and deactivate mobile data before connecting to a WLAN. It’s a little bit fiddling, but this way i never had any crashes or network losses.

1 Like

:face_with_monocle: yeah, would be nice to find a way to access any network…

does anyone have an idea how i could get a new update or a possibility to use WLAN or mobile data or phone network? I’m pretty lost at the moment but hesitate to buy a new phone (again! my XperiaX is only roughly 1 year old!)

Surely you can just reflash it.
I seem to recall that there was something about people losing network after an update with some strange OpenRepos package conflicts - maybe it is worth searching… (no i really don’t have more clues)

Why on earth would anyone buy a 5+ year old phone?
Especially with the Android runtime and kernel stuck in the past.

Is there a chance to access the phone via USB and fix it or downgrade to 4.4.0.64?

I don’t know how I could do that. Any ideas? Otherwise I’ll probably have to buy a new phone. or does anyone else has ideas how to fix my issue?

I have had Experia AX2 for over two years, I have made all the updates without problems. The only problem encountered is that every now and then, it is not clear why, the phone calls are not heard or the person does not hear my voice. Restarted the mobile returns to work. At the moment I have the 4.4.0.64 and I am waiting to see the connection problems mentioned in the thread solved, since it is not possible to downgrade the version.

If I were you i would start a new attempt and reflash the phone new. So, switch off, boot into flash mode and reflash. Also i would new download the flashing image from Jolla and also the blob from Sony. Maybe some file was damaged on flashing before.

When my XperiaX went pear shaped, a re-flash worked fine and it functions really quite well now. It’s on 4.4.0.58 and I hesitate to upgrade it beyond that.

NO WARRANTY!!! But I did downgrade successfully my Volla to …64, as it did no more work after upgrading from 4.4.0.64 to 4.4.0.68 .

But only a few, but important, apps did no more work on …68, network always worked.
Now, after downgrading back, everything works again except video camera (saving the recorded file).

Thanks a lot @Seven.of.nine and @DrDweeb
I actually reflashed after some hassle and now network appears to work again. So the rest of the evening is re-installing apps…
Thank you!