[Xperia 10 III] Phone crashed after installing 5-6 apps from Jolla Store

Hello ppl!

So, I finally got my hands on a brand new Xperia 10 III, and spent a whole day transferring my data (app and user) from my Xperia 10 II.

After successful data restore, I used the 10 III for 1 day without any problem, and today I decided to finalize the device setup by installing a few apps from the Jolla Store.
Right after the app installation, and while everything seemed to be OK, I tried to organize my app grid. I copied a few apps into a new app folder (by long press and drag&drop), and when I copied the last (literally last!) app into the app folder, I got an instantaneous notification regarding a serious error (unfortunately, the notification showed for milliseconds, so I did not have the time to read more details), and the device froze. The time-line is:

  1. Error notification popped up
  2. Suddenly, app drawer and upper menu were drawable, but blank. Also the notification page did not show the weather part, and no notification.
  3. after 20-30 secs in the above state (2.), the phone froze. Screen ON, not responding to anything (touch or power button).
  4. I left the device like this for a few minutes, just in case it was trying to recover.
  5. After a few minutes, the device turned OFF the screen with the red notification light turned ON.
  6. Again, I left the device as-is for 20-30 minutes, but nothing changed.
  7. I then pressed the Vol+ and Power buttons to soft reset. It did reset, but then the device is stuck in the SONY logo

Does anybody know if I have a chance of recovering the phone without loosing anything?

Thanks in advance!

1 Like

This may help:

Let us know how you get on, hopefully a full reinstall won’t be required, but it doen’t sound good.
FWIW, I don’t think it had anything to do with drag’n’dropping icons.

Unfortunately, it seems that the problem was something hardware-wise… :confused:

The only way to make it work again was to reflash, but after that, the following happened:

  • The phone modem has now issues. Although there is signal, whenever I make a phonecall, the call drops after 1-2 seconds. When someone calls me, he gets a message that the dialed number is out of order due to technical issues(!). Tried flashing back to Android with both EMMA, and then with newflasher (latest firmware), but the problem persists. Also tried other SIM cards, tried changing to 3G, 2G. Nothing changes the situation.
  • My MicroSD was completely wiped, and blank default folders were created (Documents, Downloads, Ringtones, etc). Thank God I managed to recover 99% of my data.
  • During the 2-3 recovery attempts (SFOS and Android flashing), the camera could not get initiated. After the last attempt to reflash SFOS, its back online.

I’ll propably take it to SONY service this week. Possibly bad luck with hardware…