XA2 died - no led, no usb response


about two month ago I installed Sailfish_OS-Jolla- on my new XA2 (h3113, single sim, german). It worked well until I tried to migrate my data from my JollaC to it, using backup/restore from settings (“Einstellungen” - “Datensicherung”).

During restoring the data on xa2 the Phone hung at about 60%. I was able to turn it off, but could not turn it on again - no led on, no other sign of live. Also plugging in USB did not show any sign of live. After two days the led suddenly lit red when plugging in and I could restart the xa2 and use it again. It worked fine for some weeks - until last week.

What happened? I connected it to the USB charger when ~30% capacity was left. After a while I saw the led flashing white, but no notification was on the screen and charging still in progress (but nothing which might hint an issue). Next morning it was dead again (which is now over a week ago) and I could not restart it since then. I tried everything: vol up+power/vol down+power/only power/only vol up when inserting usb to power. No sign of life: no led, no screen, no vibration, no usb communication with pc, nothing. To be honest, at the end I even opened the phone (desperate times - desperate measures) and disconnected/reconnected the battery. Did not change anything

Now two questions:

  1. is backing up/restoring data between different models (JollaC - XA2) dangerous?
  2. is there still a chance, to get the device working again (except the combination of volume and power on button triggering - these I have tried to exhaustion)?

Best regards,

Have you tried the option Reverting Xperia back to Android

I’ve tried it (with the EMMA tool and pressing one of the volume buttons together with the power button while inserting USB cable): the LED which should turn green remains off, and nothing happens (even in device manager no device appears). Also the EMMA tool still displays “Connect a Phone or an Accessory”. It seems really to be bricked and thus behaves like one.

Please do the combination of volume and power on buttons once more. Then, try to force the phone to the fastboot mode (blue LED lit) and reflash Sailfish OS to it.

I pressed the volume+power button - again and again (with and without EMMA running). The phone does not enter fastboot nor give any signs of life.


Presumably you also tried inserting charger microUSB directly after disconnecting/reconnecting battery, although you don’t specifically mention this sequence as have XA2 upon which had to periodically do this? Crazily I have now had to install /e/OS on this spare as got tired of it dying on me.

I have tried it now (directly to charger after disconnecting/reconnecting; immediately to pc after disconnect/connect) - previously I connected it to the computer after disconnect/reconnect battery (current battery voltage 4.25V) as I think that fastboot might only be triggered when connected to devices which might send commands. Also tried running without battery - without luck.

I decided to face the truth - I’m a proud owner of an almost full blown XA2-spare part set in a neat elegant smartphone housing :wink: So I ordered now a used XA2. In the meantime my trusty, old, blind (dead camera) JollaC accompanies me