[Vanja Rauma] Contacts gone

REPRODUCIBILITY: On update
OS VERSION: Vanha Rauma 4.4.0.64
HARDWARE: xpERIA 10 ii
UI LANGUAGE:German
REGRESSION: Maybe

DESCRIPTION:

On first update to a (with fresh license) recently prepared phone with newly - via file transferred over bt - imported contacts, all contact info gone.
On second update, same result.
No patches / openrepo apps installed.

PRECONDITIONS:

Have some contact numbers saved in your contact agenda, imported via file as well as added by hand.

STEPS TO REPRODUCE:
===================’

Upgrade.

EXPECTED RESULT:

Contacts should not be nuked

ACTUAL RESULT:

Contacts ground zero / All erased

Where were your contacts stored? Can you please update your bug report :smiley:

How did you import the contacts, what did you do to verify that they’re gone?

Im sorry i dont understand; is the contact agenda / app not clear ?

Via .vsd file(i think). They were there for a long time with many reboots / repower cycles

There are various possibility to store your contacts. CardDAV, phone, etc. Which option did you choose?

Other point I don’t understand: You updated your phone. Does it mean, there were contacts before updating your phone? Why do you write “import”?

2 Likes

I think I experienced something similar when flashing Xperia 10 III and restoring backup-file from Xperia X: contacts, phone calls and notes didn’t import/wasn’t restored. I have all contacts in place now, but I’m not sure how I managed to do that :slight_smile: If I remember correctly, I unpacked the backup-file from Xperia X on the laptop, copied the Contacts folder to the phone (Xperia 10 III), chose restore from ‘Settings - Apps - Contacts - Import from file’ and pointed it to the contacts file in the Contacts folder (I don’t remember what file format it was, but it worked). I did something similar with notes (phone call history I don’t care about, there will be new incoming calls).

The import happened first by sharing a contacts file via bluetooth from my xperia to the xperia 10 ii; then all ok UNTIL the first upgrade of the os (vanha rauma?); after which the contacts where gone
I re-added the ones i use the most, but then the latest update came amd wiped them again.

No caldav / sync. Just two google accounts (one for work + a private one); both with contact sync OFF

Thanks for clarifying. Can you add the information that you imported them via file into the contacts app and that they were not visible in the contacts app afterwards to the first post?

This makes it easier for the developers, if they now exactly how this happened.

Are you using the patchmanager or any apps from openrepos that work with contacts?