The Volla 22 (Gigaset GS5) Thread

Another note. After turning off the unused interface (on the G5 it was 0 on the rephone 1) I noted that the wlan selector (gui) no longer showed 3 but only 2 interfaces. But there is only one visible with # ifconfig, although # ip addr always shows 2.

1 Like

Just wanted to say that deactivating and uninstalling all patches and then reinstalling patchmanager after a reboot helped. Patchmanager is working again. So it was probably just an irritating coincidence.


My rephone is my daily. I better wait til 0.24 is ready. Thanks so far for a stable device.

Do every users of a Rephone and GS5 have this SIM registration issue or only some?
Asking to determine: if there is something to enhance in the installation process that could avoid this issue or if there is nothing to do as all are concerned.

I have never had any issues. But I have to say, that I have deleted the PIN for the SIM a long time ago. I rely on the device PIN and that I have a Prepaid SIM.

1 Like

This is no so good news: apparently Gigaset is bankrupt :frowning:

Maybe, they should sell a huge number of phones with SFOS …

1 Like

It’s not quite as dire as it sounds, but, just like Jolla, they are doing a restructuring. Since the ‘Dect’ part of the business is what’s leading the losses, they aren’t gone just yet. I would guess they are just seeking protection from extractive creditors. They claim to be continuing production, but the wages to the end of November are being paid by the state. Keeping my fingers crossed.


Thanks for the hint @Fellfrosch

So I thought : “Great idea! I can try to disable the SIM PIN code into the XA2 and then try into the GS5”
:joy: Hah, in Settings → PIN code, the “require PIN code” switch is not active (PINcode is enabled though).
When I click on it, XA2 infinitely asks for the PIN code, saying it is wrong, even when I enter the correct code, and that I have 5 tries left. This forever, even by entering a wrong code. Very forgiveful!
" errare humanum est". My phones are humans. As surprising as a good art exibition!
(Swisscom SIM card)

Wow, @Fellfrosch many thanks!
Your remark about disabling the PIN code helped me a lot.
Disabling both PIN codes solves the need of multiple reboots to use the SIMs.
But this is a bit dangerous in the event of theft.
So, I kept the PIN for the regular subscription and removed it for the prepaid one.
This way, I just have to disable the regular subscription SIM before to reboot and re-enable it then.
So, I can daily use the GS5 again, great!


@ric9k great to hear.

I have a new issue. I’m not able anymore to use the second cam with advanced camera. Main Cam and Selfie Cam are working. But if I switch to the second Cam thew vie gets black and after that I can’t use advanced Camera anymore until I restart it. Anybody else has this pronlem?

I am to suffering from this camera problem with my volla 22.

1 Like

Yes, I also have this issue UNLESS I set the resolution lower first. So, with camera 0, set to 1920x1080 and switch to 1 and 2 and it works. But camera 2 at any higher resolution is no go. That’s tested with the GS5 … not sure what the case is on the rephone.

EDIT: but advanced camera is also not reporting the range of available resolutions. Just switch to jolla’s camera and you get camera 0 taking photos at 6000x8000 pixels. All a bit strange.

1 Like

Here (GS5 in, only the narrow cam + selfie cam are working in stock app.
The three cams are working in Advanced Camera.

That’s exactly how it used to be. But for some reason that has changed. Have you already installed the last small update?

No, I didn’t install the .24, as it has been said as not yet safe, IIRC.

Telling you, this phone is alive, able to make jokes! :grinning:
When I plug the SFOS GS5 into my Debian PC:

I meant the small update from .21 to .21. :wink:

@poetaster how di you get that high resolution with stock camera?

I have found a way to use camera 2 again: before switching to it toggle to video recording then you can choose cam2. When it is active toggle camera modeto photo again.

1 Like

I have a rephone and tried to install vollaos. by ubports-installer. Now the smartphone does not boot anymore. No recovery mode and no fastboot mode. tried everything, no chance. sp-flash tool detects chip MT6768, but I need firmware for rephone or for Gigaset GS5 . I can’t find it on the web. rom for Volla 22 does not contain the urgently needed scatter.txt. I have already contacted German forum members for help, but smartphone won’t boot.

“IS THERE ANYBODY OUT THERE” who can give me another solution? Or maybe even has the firmware I need?


translated by :wink: :wink: :wink: :wink:

I didn’t ‘do’ anything. That’s just what I get! On the rephone, default resolution is 4608x3456. I really don’t get it. I do believe I may have added some settings on the one or the other. I’ll have to check.