Tama devices: flashing

I have an xz2c which I upgraded (rather than reflashed) from the 32bit port to the 64bit, with no apparent problems. Recently I’ve had trouble with nextcloud contacts, duplicating ad infinitum and my efforts to delete the contacts db didn’t help.
So now I want to start again and reflash to sfos 4.3
. My question is can this be done on top of the existing installation, or do I have to go back to android first? TIA

You can just flash it. No need to go back to android. At least thats what i did when we moved to AOSP 10.

I tried, this is what I get:

Searching device to flash…
Found H8314, baseband:, bootloader:
Found 1 devices: BH901NC8CU
Fastboot command: fastboot -s BH901NC8CU
Flashing boot partition…
Sending ‘boot’ (20276 KB) FAILED (Status read failed (No such device))
fastboot: error: Command failed

Have you checked whether it is trying to flash to “slot -a” or “slot -b”?

yes, it’s a. I can’t think of anything else to check.

Plz check other cables, try an usb2 hub and if you use linux you need write rights on the usb device…

Thanks to everyone who helped, problem solved. I had android-tools on my machine; reinstalling did nothing so I installed android-sdk-platform-tools and that did the trick.

1 Like