SSH inside docker build engine not starting in newly installed SFOS SDK [Works]

Hi there,

I’m currently trying to add the aarch64 target to the SailfishOS SDK on my Dev Machine. unfortunately this always fails with the following Message:

kex_exchange_identification: read: Connection reset by peer
Connection reset by port 2222

My system is ArchLinux with current updates, Latest non-EA SDK (, Docker Build Engine.

Since it has helped in the past, I tried to completely wipe the SDK (uninstalling via SDK Maintenance Tool and removing all configs etc… from my home folder) and reinstall it from scratch, which doesn’t change a thing, the error occurs in the installation when I select the aarch64 build target there, or if I try to add it afterwards with the Maintenance Tool.

Furthermore, connecting to the Build Engine from the IDE is also not possible (From the Settings, or by trying to Build anything). It always shows Timeout and the aforementioned Error Message. So I now can’t use the SDK at all (it worked a while back with the docker build engine (I think latest 3.x release of SFOS), but I didn’t use it for a while)

I did look into the running docker build engine and saw, that there is no running ssh-daemon or open port 22 there, which would explain the Message (since nothing is there to connect to via SSH).

So does anyone have an idea what could be the problem, and even better how to solve it?

Btw. I can’t get anything useful from the build engine with docker logs or similar, does the build engine produce logs, and if so, where are they?

Thanks in Advance,


Possibly the cgroups v2 issue - please check Issues with installing sailfish sdk (docker) with debian bullseye (11) - #7 by martinh

1 Like

Thanks for this hint, I didn’t find this thread when searching for my problem earlier.

I had to do another reinstall of the SDK after adding the Kernel Parameter described in the linked thread (just adding the parameter and rebooting didn’t fix it), but now it works fine.