Sony Xperia 10 no WiFi device

REPRODUCIBILITY (% or how often): 100%
HARDWARE (Jolla1, Tablet, XA2,…): Sony Xperia X
REGRESSION: (compared to previous public release: Yes, No, ?): No


I have a newly flashed Sony Xperia 10 plus (dual-SIM) and have the same situation as described here

No of ideas in other topic helps.

I flashed 3 times.

Followed this instructions (can’t put a like because i am new user : -D )

Use Software binaries for AOSP Pie (Android 9.0) – Kernel 4.9 – Ganges (latest) v.9 form here

I tried to download and flash with vertions 8 and 7 but the ./flash script can’t find it and don’t flash the device. Output is SW … not found.

I have no ideas any more what can I try to get the WLAN works,


In Android WiFi Works, I had android 10 but downgraded it to Android 9 to install Sailfish like in howto


  1. Flash Device
  2. Start Phone
  3. Enjoy (without WiFi)


WiFi should work


No WiFi Adapter found, No Mac Adress in the info view


I am having the exact same problem. I’ve also searched around and have been unable to find a solution. I feel a little cheated since I paid for the full version of SailfishX and I can’t get the wifi to work.

Mobile data works perfectly fine but I can’t afford to constantly use mobile data.

Help would be greatly appreciated!

i had a sort of similar situation in my case imei was missing and later i lost wifi mac address too. have you tried going back to Android is wifi working?

Yeah. I’ve gone back to Android and flashed Sailfish back a few times. It works on Android but I seem to have no such luck back on sailfish

I have the exact same problem, no wifi, wifi works in Android, tried several re-flashes, still no wifi. 3G works fine.

same her. i reinstaled android a few times , and tested the wifi and it works, so in installed sailfish probably 6-7 times and then it works again . last time i downloaded sailfish x file from download link at jolla and reinstalled sailfish x from that file that did it for me , all is good now for me.