[SOLVED] Sony Xperia XA2: switching from Lineage 16 to SFOS fails

I am a former Sailfish user willing to reinstall SFOS on my Sony Xperia XA2 H4133.
Since my first SFOS installation, I had been switching OS: first Lineage 16, then 17, then back to 16, my current OS.

When trying to flash SFOS again using my Raspberry Pi, the “./flash” command displays an error : “0 device connected”.
However, “fastboot devices” lists my phone as connected. “fastboot getvar all” shows information about my device. The lines seem OK, even though I noticed that my phone product is wrongly displayed as H3113.

Did somebody encounter the same problem? Any ideas to fix the device recognition issue?


PS: I am using my Xiaomi Mi 10 USB-C cable as I have no access to my other cables, which are currently abroad.

Dumb question.

What android release does Lineage 16 translate to?

android 9 or Android 10?

Hi thank you for your kind reply.

Lineage 16 is based on Android 9 (Pie).

While using Android 9 Sony binaries and latest SFOS image, fastboot now seems to detect my device. However, it displays it as a H3113 model and not a H4133. It therefore refuses to install the H4133 binary. How come the bootloader displays corrupted information ?

When booting, Lineage does recognize it as a H4133.

Another dumb question.
Is the HW really a Dual SIM (4133) or a Single SIM (3113)?

Dual SIM (I confirm it is a H4133 from Hong Kong). I already used SFOS on it for several months. It seems switching to Lineage corrupted my firmware somehow. Now I think I should try to flash a H4133 firmware to repair it. What do you think?

Hmm, not sure.
Would wait for more input from others…

Alright, problem has been solved.

I did a software and firmware update of the phone with the official Emma tool on a windows computer. This made the phone reboot into a fresh Android 8.0 install.

Fastboot then detected the phone as a H4133; flashing of Sailish went smoothly.

Thanks all.


Wonderful. :slight_smile:
You know you can mark your post above as ‘solution’ ?