[Release notes] Vanha Rauma

Well, my upgrade experience is not promising. Xperia X.

Battery flat in just a few hours. (Pic 0)

The culprit would appear to be alien_resource_mgr. (pic 1)

So I rebooted and android.process.media (pic 2)

was chomping away at 30+% according to Crest, but seems to be declining slowly. I guess this is some sort of Android preparation task, but it’s fairly heavy on the device.

Either way … not usable at this point

  • If I start the lockscreen camera, and then swipe away to do something else. The camera process just hangs there chewing 18-19% according to Crest

  • /usr/bin/lipstick -plugin evdevtounch:/dev/touch… is looping at 43% constantly

It seems the SIMS don’t work and neither does the WAN. I fear another re-install is upon me :frowning:

Edit: A complete re-flash to 4.3 and upgrade to using sfos-upgrade (the built in function did not work at all) seems to have resolved the network issues. I have disabled Android

Attempted updating. Got a message that updating is not possible, reboot. After reboot. No connectiviti whatsoever, no WIFI no Mobile date, nothing. I cannot even run the backup restor! What do I do? Help!

Same here. Should I reset the device?

I would suggest to download a image as a reserve to have an option for reflashing the phone with a working system until these problems are solved, for the case of a full crash.

That will be a solution, but there is now connectivity. Where and how?

Kudos to @nephros for providing a quick answer with the right quote from Storeman Installer’s description at OpenRepos.

Note that I vastly expanded the paragraph nephros quoted to be more comprehensive in order to become the second bullet point in the section “Important notes” of Storeman Installer’s README at GitHub.

To install Storeman on SailfishOS 4.4.0, please use this guideance.
As the install method via file-manager seems to be broken in SailfishOS ("xdg-open not found"; also reported here and with some analysis here), one currently has to install downloaded rpm files via:
devel-su pkcon install-local <whole-rpm-filename>


With should create a wiki to follow these bugs.

1 Like

Whisperfish, patchmanager and Storeman removed before update .Post update .rpm downloaded from OpenRepos won’t install giving ‘xdg-open not found’ error. UPDATE Ignore-just seen @olf post on how to install Storeman. Thanks

I built ncurses-compat-libs myself, with manually removing the dependency to the base package. I tried it on my XA2 Ultra and X10II and they both now can at least start fish and browse around a bit with it. You can find the packages in the ticket.

Install them at your own risk! Remember to remove them, too!

fish issue #2


Regarding xdg-open: it’s caused by the forced sandboxing. I hacked up a quick fix that hopefully works but be careful it is not tested. I will do my best to provide new builds on Sunday. Until then, everyone can just build File Browser (git main) themselves or fetch this file: https://github.com/ichthyosaurus/harbour-file-browser/blob/main/qml/pages/FilePage.qml

EDIT: File Browser’s core feature - showing files - is impacted as well. Here’s how you can fix that for now:


OK, I’ve reset the device. It kicked me back to 4.0.OS. Got the WIFI back, after a couple of restarts also the SIM card.
Then when I tried to install the next update the system asked me to uninstall like a 100 different things. So… it will not be possible.

Sometimes you can just ignore that warning.

Great ! The internet connection bug between cellular and wifi in Android is fixed !
Thanx a lot for all !
Sailfish forever :wink:


Thanks, direc85! That should have got me on my way again - and allowed me to recompile fish - which would have probably linked it against the newer ncurses. However, I cannot install the package, because xdg-open is supposedly not found.

I cannot install it through the terminal, since the terminal is broken. It’s a chicken-and-egg problem. I need the terminal to fix the terminal.


Yes, everything seems to work. However Amazfish app seems not work, however.

Xperia 10 - my update stucked on 100%. I left phone for night. Had to restart phone in morning. It works, but i have no internet in Sailfish OS, but in android works. Any solution?

1 Like

Shell from recovery mode?

Just tapping the dowbload notification, or opening it from downloads works just fine too.

BTW, the obs link is broken, and the repos never refresh. Is there another thread for this?

1 Like

Bit hardcore update:

  • downloaded → ok
  • started installation → ok
  • device booted-> ok
    at this point:
  • device didnt restart, had to put it on
  • progress bar screen appeared but got stuck at 100% → reboot was necessary
  • after reboot, al normal?

xperia 10 ii
fingerprint sensor enabled

quite a rollercoaster :slight_smile:


That indeed is a chicken-and-egg problem…

And you can’t click the downloaded link notification either, because GitHub forced me to zip the files to be uploaded.

1 Like