[Release notes] Vanha Rauma

It looks like 4.3 provides libtinfo.so.5, but not libtinfo.so.6, and 4.4 provides libtinfo.so.6 but not libtinfo.so.5. That would mean separate builds for 4.3 and 4.4 for fish shell at least. Or, I’m missing something, which is also quite likely :slight_smile:

Edit: Changelog has [ncurses] Enable ABI6 and move ABI5 libs to a separte package. but I can find no package to offer ABI5.


If passilic is started normally, it’s unable to list saved password. As a workaround, it’s necessary to start from terminal.

No VOLTE yet? Just checking on this much needed feature.


For me GPSInfo launches from the icon, and it asks for permissions (which I should narrow down actually). Make sure it’s the OpenRepos version and not the Jolla Store version, OS upgrades tend to downgrade OpenRepos packages to whatever version Jolla Store offers…


I can’t install Storeman: It complains …“nothing provides libsolv0”.


Damnit, this will break basically everything running on console. Hopefully the mentioned compat package makes it into the final release.

EDIT: according to this there should be a compat package called ncurses-libs5. Hopefully this will resolve the libs correctly for old binaries.


EDIT: For detailed information on how to deal with this, see @olf 's guides below:

Original post:

I think that is because the install process picks up an older version of the storeman package (likely from the mentaljam Openrepos repo).
Current versions (from Chum) do not link against libsolv0.

So, download a current build for 4.3 from Chum and try with that.

Also, the description for Storeman-Installer on Openrepos states:

  • Every SFOS release requires a configured OBS repository. Therefore Storeman installation may not be available for some time after a new SFOS release until maintainers configure a new repository. This is especially true for EA releases
1 Like

I tried it with download from Chum repository built for 4.3. and get the same error

None of the versions on Chum works for me, alas.

Updated to Rauma via command line and after reboot i can not activate SIM nor WIFI. Also no calls can be received.
Any attempts to get network up failed. Bluetooth also not working.

Any ideas?

ifconfig up also nothing; tells me no name even (no eth0 no enp4s0)

Installed the update, it actually worked through the GUI on the first try. It seems to work OK, but I’ve lost the ability to open a shell, because I’d previously installed fish and this no longer wants to start, since libncurses apparantly no longer exists:

fish: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

I cannot login through SSH either, requesting a different shell is somehow simply ignored. This is problematic, since I always use the terminal to check whether the phone has gone off the rails (i.e. ofonod has gone into a feeding frenzy on my battery) and now I cannot open it, nor install other applications.

@martijntje Have you try recovery mode to uninstall fish shell?
And change default shell then

Thanks for the update. It seems less exciting in new features than previous ones, mainly bug fixes. But it looks the underlying platform is continuing its modernization (APIs, browser, etc.).
Looking forward for the stable release to install it on my device, and I wish VOLTE will come sooner than later (that’s one feature I’m aiming for as it will, hopefully, improve call quality a lot).


The same here on X10: On trying to install from .rpm file, phone says: xdg-open not found !

it reports 'nothing provides ‘libsolv0’ needed by the to be installed harbour …

Yes, I tried using fastboot to boot hybris-recovery.img, but it’s stuck at “sending”. No idea what’s wrong there, I am using a data cable and when I remove it it immediately exits with an error.

Ok, looks like we have some sailjail glitches now:

  • Syncdings cannot startup syncthing anymore
  • AdvancedCam pictures from sdcard are not shown in gallery
  • Sailpass ist not able to select the sdcard (where I have my keys)
1 Like

I have now updated one of my X10’s from to 4.4 and can report:

In general, it worked fine and phone ist still OK. edit: this means, it is not crashed and useable, but there are some bugs.

At beginning, it requested to remove
harbour-owncloud-daemon and

Storeman, I removed in ‘normal’ way, by long tap on app grid and then tapping the x,
harbour-owncloud-daemon i could deinstall with pkcon remove harbour… without problems.
gstreamer1.0-libav reported ‘This request will bring your system to crash’, so I skipped it.

After the update, phone booted and some problems occured.

  1. File browser shows only the half of the files and directories, despite the missing files and directories are really present via CLI or ssh access from laptop.

  2. All apps requested all permissions for all and everything, so I started all of them one by one to store all permissions before proceeding.
    For what asks e.g. MeeCalc, Quanto Fa or Fotokopierer for access to Audio, Bluetooth, Internet, Camera, media index, microphone, net content, NFC, location, removable media???

  3. Vodman no more working, requests missing Python,

  4. On installing Storeman from downloaded .rpm file, it reports: xdg-open not found. Installation failed. So I have no Storeman at the moment.

The rest including my several tweaks seems to work fine.
Still working fine: Change of tethering adress block still present,
EU soundlimit disabler - still OK
Ambience white-on-black - still OK
Hide tutorial - still OK

But I see no way to install Storeman at the moment. Does anybody know more about this?

edit: Lls video player plays videos but updating the Youtube downloader leads to an eternally spinning wheel.

Keeping older devices in the train is much appreciated, thank you!


@seven.of.nine Have you tried storeman-installer?

1 Like