Q: How can I reflash my phones with a new SFOS Version?

Sorry for this newbie question, but I can’t find any manual for my problem.

My phones (Xperia 10) were initially flashed with SFOS 3.3 (the one) and SFOS 3.2 (the other).
So, after a factory reset (sometimes this is necessary) I always get back to this old versions and have to update in 3 or 4 steps to:
3.4 (stop release), then
4.0, then
4.1, then .

This procedure takes one afternoon time and causes abt. 2 GB data traffic on my internet access. I would like to reflash my phones, so that I come to SFOS 4.1 after a factory reset.

What have I to do for reflashing the phones to a new version? I could not find the flashing instructions, and in my case it may differ from flashing a new Android phone with SFOS. Has anyone a hint or advice?

And: I have 2 paid licences. Will they stay valid after entering the credentials into the Jolla account setup?

edit: I downloaded the free version installation images of SFOS:
Sailfish_OS-Jolla- and
Sailfish_OS-Jolla- right now.

Can I use these files for reflashing and anyway keep the licence?

Just flash as per the official instructions: Sailfish X Installation Instructions - Jolla
Licenses remain valid, they are tied to IMEI.

1 Like

Read about the licenses here:

1 Like

Yes (to all three questions)!

  • License: See answers above.
  • There is only a single archive of the files for flashing for each device / model (i.e., no “free” vs “paid” version exists; you make the difference by logging in to a Jolla account).
1 Like

Thank you all for the answers!

I tried but it did not work and I’m not sure if I did everything right. I downloaded the SFOS zip and the Sony zip and unzipped both. Then I put the Sony .img and all the single files from the SFOS zip into the same folder. It looks like this:

andrea@andrea-TravelMate-P249-M:~/SFOS_flash/X10.double/Sailfish_OS-Jolla-$ ll
insgesamt 2372408
drwxr-xr-x 2 andrea andrea 4096 Sep 6 17:46 ./
drwxrwxr-x 3 andrea andrea 4096 Sep 6 17:46 …/
-rwxr-xr-x 1 andrea andrea 97792 Mai 20 13:03 AdbWinApi.dll*
-rwxr-xr-x 1 andrea andrea 62976 Mai 20 13:03 AdbWinUsbApi.dll*
-rwxr-xr-x 1 andrea andrea 1314816 Mai 20 13:03 fastboot.exe*
-rw-r–r-- 1 andrea andrea 652763592 Mai 20 13:04 fimage.img001
-rwxr-xr-x 1 andrea andrea 1298 Mai 20 13:03 flash-config.sh*
-rw-r–r-- 1 andrea andrea 4688 Mai 20 13:03 flashing-README.txt
-rw-r–r-- 1 andrea andrea 7844 Mai 20 13:04 flash-on-windows.bat
-rwxr-xr-x 1 andrea andrea 14735 Mai 20 13:04 flash.sh*
-rw-r–r-- 1 andrea andrea 288 Mai 20 13:03 hw-release
-rw-r–r-- 1 andrea andrea 20533248 Mai 20 13:03 hybris-boot.img
-rw-r–r-- 1 andrea andrea 22401024 Mai 20 13:03 hybris-recovery.img
-rw-r–r-- 1 andrea andrea 688 Mai 20 13:04 md5.lst
-rw-r–r-- 1 andrea andrea 231 Mai 20 13:03 os-release
-rw-r–r-- 1 andrea andrea 1506294032 Mai 20 13:04 sailfish.img001
-rw-rw-r-- 1 andrea andrea 225472684 Mai 21 2019 SW_binaries_for_Xperia_Android_9.0_2.3.2_v9_ganges.img
-rw-r–r-- 1 andrea andrea 323864 Mai 20 13:04 vendor.img001

In the console, I went to this folder. Then I checked for the android-tools-fastboot, computer reported that they are already installed and up to date. (chapter 3 of the howto)

Then I switched off the phone, then hold Vol UP and connect USB cable. The LED showed: short blue … short red … constant blue.

Then I entered the command

andrea@andrea-TravelMate-P249-M:~/SFOS_flash/X10.double/Sailfish_OS-Jolla-$ sudo ./flash.sh
[sudo] Passwort für andrea:
Detected Linux
Searching device to flash… (for 5 minutes!)
andrea@andrea-TravelMate-P249-M:~/SFOS_flash/X10.double/Sailfish_OS-Jolla-$ sudo bash ./flash.sh
Detected Linux
Searching device to flash…
Found FAILED, serial:CQ3001MRKJ, baseband:FAILED, bootloader:FAILED
No valid devices found.
andrea@andrea-TravelMate-P249-M:~/SFOS_flash/X10.double/Sailfish_OS-Jolla-$ sudo ./flash.sh
Detected Linux
Searching device to flash…
Found FAILED, serial:CQ3001MRKJ, baseband:FAILED, bootloader:FAILED
No valid devices found.

Also I am not sure if “sudo bash flash.sh” is a typing error on the howto on the homepage. Shouldn’t it be “bash $: sudo flash.sh” ? Therefore I tried both.

What mistake did I make?

Could be that you have the USB3 bug where the phone goes out of sync with the fastboot application and just refuses to work properly. (Test with running fastboot getvar product a couple of times, and if it fails intermittently that’s what’s going on) If this is the case, try a USB2 port, or a USB2 hub in-between. Some few USB3 controllers do work though.

No sudo bash ./flash.sh is not a typo, but also generally not necessary. It is a “just in case” for those running other shells.


More details WRT workaround for USB3 issues, see chapter 2 “Flashing SFOS” here:

1 Like

Thank you @attah !
It worked like a charm at the first try, using an USB hub between the laptop and the X10!

It was a 10,- Euro USB hub with a USB 3.0 pigtail to computer and 3 white and 1 blue USB jack that did it. Using one of the white jacks worked immediately and perfect. The working CLI command was exactly the one from the howto on the Jolla homepage. (So I have learned that all my former failures came from the missing hub)

1 Like