Proxy Server Refusing Connections

Anybody else ever get this? Only happening on wifi; mobile data works fine.
My mobile data provider uses proxy for apn, so I set ‘global proxy’ in apn settings, but didn’t think wifi would depend on that…

Update - so disabling global proxy solves the problem with wifi.

Any ideas how to get it ro work with the proxy enabled?

It may be possible to restart the proxy server!

This post was flagged by the community and is temporarily hidden.