OSM Scout Server Fix for 3.4

After updating to the latest 3.4, I noticed OSM Scout Server (needed for Pure Maps) no longer worked. I did a clean flash/update and it wouldn’t install from Storeman, due to a version discrepancy in libicui. I needed OSM Scout Server (and Pure Maps) because I don’t like the Android solutions. I figured out a way to get OSM Scout Server installed and running perfectly. Please note, this may not be the most ideal way to do it, but it WORKS!

Symlink the existing version of libicui to the version required for OSM Scout Server (this isn’t ideal, but I’ve noticed no bad behavior or issues):

devel-su
ln -s /usr/lib/libicui18n.so.66 /usr/lib/libicui18n.so.63
ln -s /usr/lib/libicudata.so.66 /usr/lib/libicudata.so.63
ln -s /usr/lib/libicuuc.so.66 /usr/lib/libicuuc.so.63

Download OSM Scout Server:

curl -C - --output osm-scout-server.rpm https://openrepos.net/sites/default/files/packages/6933/harbour-osmscout-server-1.17.0-1.132.1.jolla_.armv7hl.rpm

Install the RPM:

rpm -i --nodeps osm-scout-server.rpm

You’ll need to do the same for mimic, to get text-to-speech working for turn by turn navigation. Download mimic:

curl -C - --output mimic.rpm https://openrepos.net/sites/default/files/packages/6933/mimic-1.2.0.3-1.9.1.jolla_.armv7hl.rpm

Install it:

rpm -i --nodeps mimic.rpm

I’ve tested everything very thoroughly, and I finally have an offline maps solution working on 3.4. Please let me know if this helps you, or if you have any further questions. Enjoy!

7 Likes

I think it isn’t good practice to link different versions of libraries in that way - things may break that you may not be expecting.

2 Likes

I suspect OSM Scout Server, like Amazfish wont be available for 3.4 until that release is on OBS, as per the great OBS closure thread, ccn@rinigus

1 Like

I know, it was the only way to get it going fast. I’ll check out your rpm though, thanks!

As OBS target for 3.4. has been added, OSM Scout Server is available at OpenRepos for SFOS 3.4.0 users. Starting from 1.17.1, OpenRepos repository RPMs will require SFOS 3.4.0. For SFOS 3.3.0 users: please use OBS for future updates.

5 Likes