Nextcloud integration won't connect at all

Can somebody confirm that the Nextcloud integration works out-of-the-box?
Every device is able to connect to my nextcloud-server, only my SFOS devices (XA2 4.0.1.48; XA2 Ultra 4.3.0.12) refusing to do so. It won’t work with the integration and even not as a caldav/carddav account.

Surprisingly via DAVx5 it works (on the android side)…

Does anyone got this working. Since all other devices having no issues at all, I start to believe this issue is related to SFOS somehow… :frowning:

I got no connection problems with SFOS and nextcloud.

EDIT:
Could you check the path settings?
Settings, accounts, nextcloud, dropdown menu advanced settings.

user
userpassword
https://my.server.adress.org:55555

WebDAV: /remote.php/dav/files/user
CalDAV: remote.php/dav/calendars/user

In .htaccess the rewrite rules are:
RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]

Nextcloud 22.2.3 running on Ubuntu 20.04

EDIT: username → user

I don’t have or need port specified. Hopefully someone else who knows more about it than me can comment on this.

Also, I see you use username as username, but the url says user. I assume they are just placeholders for safety reasons, but just to make sure: they both are the same right, and you just mixed up the names of this post’s placeholders?

1 Like

Hi ThijssjihT,

you’re right → I messed up with the placeholders. I guess the day yesterday was too long… I changed it in the original post.

I used another password without ‘special signs’ and now it seem to work. :exploding_head:

strange, I use a password with special characters. Maybe it is just some specific characters? A password containing #$^ works for me.

I’ll look into it closer this evening and keep you posted.
Thank you for your support :slightly_smiling_face:

Hi @Solidus, I confirm that Nextcloud 22 works perfectly on my SFOS devices (XA2 Plus, Xperia 10), so that your issue is surely due to a wrong configuration on your SFOS devices.

The only features that SFOS would now need to have a state-of-the-art Private & Secure open source cloud support with Nextcloud:

  • SFOS app “Nextcloud File”: to easily browse files on the cloud using a native SFOS app

  • SFOS app “Nextcloud Talk”: now in Beta development phase, not supporting voice messages nor video-conferences. It would be awesome that the native SFOS app could handle both those features, especially H.265 video-conferences as on the “Nextcloud Talk" Android app.

There are a couple of apps out there that can do that.
There is also davfs2 on chum if you want to mount your nextcloud files, so any app can browse them.

2 Likes

@Solidus are you using SSL/TLS? Are your certificates valid?

Could you, as a test, have the server run on port 443? I seem to remember some components didn’t properly initialize a TLS session on nonstandard ports at some point in the past.

Hello @nephros ,
I’m using ssl/tls and the certificates are valid.
It turns out that I didn’t run into a bug, I faced a feature.

After I changed my password to another, everything worked as expected. When I tried to change back to the old one, it didn’t work anymore.

Checking the password rules it seems that my first chosen password didn’t pass the password-list from haveibeenpwnd.com:sweat:

1 Like