Missing /usr/lib/sailfish-fpd

I printed sailfish-fpd status and saw following error:

mai 25 07:24:03 Xperia10II-DualSIM fpslave[23570]: fpsettings_scan_directory: /usr/lib/sailfish-fpd: can't open directory:
 No such file or directory
mai 25 07:24:03 Xperia10II-DualSIM fpslave[23570]: fpdevice_connect_to_service: remote object init failed: OK
mai 25 07:24:03 Xperia10II-DualSIM sailfish-fpd[23567]: mrcontrol_set_active_user_cb: delayed change to user 100000

I then search for a directory call sailfish-fpd and found 5:


Has someone more information?

Are you having any problem with fpd?

Not really. I just need various try, but it works quite fine.

I did
journalctl -f | grep -E 'fpslave|sailfish-fpd'
and then unlocked it via fingerprint etc. - no output.

Then I went into settings and added another fingerprint.
Still no output.

Then I tried to add another fingerprint although there already were 5.
That’s when I got this:

fpslave[9662]: fpenroll_enter: QUIRK: cap to 5 fingerprints
sailfish-fpd[9660]: mrcontrol_set_fperror: error: FPERROR_NONE -> FPERROR_NO_SPACE
sailfish-fpd[9660]: mrcontrol_fphal_timeout_cb: fp hal is stuck; terminating
fpslave[9662]: fpcontrol_master_rd_cb: unexpected master wakeup: condition=0x10
sailfish-fpd[9660]: *** SLAVE TERMINATE
fpslave[9662]: fpcontrol_master_rd_cb: disabling master io watch
sailfish-fpd[9660]: main: sailfish-fpd terminating with exit value 1
systemd[1]: sailfish-fpd.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: sailfish-fpd.service: Failed with result 'exit-code'.
systemd[1]: sailfish-fpd.service: Service hold-off time over, scheduling restart.
systemd[1]: sailfish-fpd.service: Scheduled restart job, restart counter is at 2.
fpslave[11351]: fpsettings_scan_directory: /usr/lib/sailfish-fpd: can't open directory: No such file or directory

(removed date and host and some entries for easier reading)


find / -type d -name sailfish-fpd 2>/dev/null

fpsettings_scan_directory rightly complains about a missing directory, but I don’t think it matters.
If you go through your journal, you’ll find tons of similar entries. Unless they are very clearly labeled as (fatal) errors - don’t worry.

1 Like