Is the battery on my XA2 going dead, or is this an issue with Sailfish OS?

Hello,

Sorry about posting and deleting this twice before. Learning how to format the posts in here.

I am one of those US Sailfish OS users.

I am currently running version 3.1.0.11 (community) on an Xperia XA2 and have done so for a about well over a year with very few problems (only mild annoyances that may justify a bug report.)

I would like to go for the full version, but some of the mild incoveniences would need fixed first. I will post about those later, after I can get this fixed.

Anyway, as of this morning, when I woke up, my Sailfish XA2 Device cannot decide what percentage my battery is charged to.

The percentage on the home screen is constantly jumping around, and I am sometimes getting the “Device Will Shut Down Soon” message because Sailfish thinks that the battery is dead. A couple of times, the XA2 actually did shut down.

I tried searching the forums, and have been unable to find a post where someone has had a similar problem.

I am somewhat convinced that the issue is the battery itself, but I thought that I would check here first before going through that process since it is not a removable battery.

Thank you,

Gabriel

Try this in terminal, it should show health of your battery

cat /sys/class/power_supply/battery/health

That command simply returns Good. Thanks for the reply.

I think it is certainly the battery.

Now, at this point, even when charging, the XA2 simply gives me the dead battery symbol. I guess I can see if adb will let me load another OS, and try, but I doubt it will help.

It is nice to have good backups…

Hello Gabriel,

if the battery state returns ‘good’ you might want to check on your USB port and cable for dust or other contamination.
Then try a full charge after a reboot. A battery going dead should normally loose mileage over an extended period of time and then fail completely.
Did anything unusual happen to your phone lately?

I think you are right.

I think that it may be the USB port.

This morning, after sitting all night without it being plugged in, it actually started up.

However, it will not charge. It doesn’t even recognize that a cable is plugged in (with multiple cables.)

Nothing weird happened to the phone. No dropping or anything.

Rsync-ing over SSH right now to make sure that I have everything backed up.

I will try your suggestion after creating a 2nd backup.

But right now, I do not see any dust in the USB port.

I remember reading somewhere that the USB ports on XA2s are notorious for going out. Unlike batteries, I can actually find USB port boards on eBay, so I might actually be able to fix my phone! It seems that most of the XA2 parts available are for the Ultra.

Maybe I should just buy an Ultra, that way I have a phone with spare parts available?

The X had a modular USB-Port, I hope the XA2 has the same feature. After opening the phone, which I find quite scary, replacing die USB port seems simple. I have to clean mine every once in a while. Contact cleaning spray and compressed air are a good option but take care to switch off the phone and let it completely dry before connecting the cable.
I use magnetic USB cables so the actual connectors of the phone will not have to stand much wear.

Been a little busy, I just got a cheap Android phone for the moment to use until I figure this out.

I have been thinking about just getting an XA2 Ultra, but here’s an update on this…

  • I was able to get the phone to start a couple of times. The times when I am able to start the phone seem to be random. Any other time that I try to start the phone, it comes up with the dead battery symbol that I have drawn below.

  • When attempting to charge the phone, there is an odd symbol that pops up on the phone that I have never seen before. I’m assuming that this symbol means that the battery is dead. If that’s the case, that the battery is dead, or the phone thinks that it is, even when charging, I think that points to the battery itself being the culprit. I’ll include an approximation that I made of the symbol in XPaint.

*Xa2BatteryPluginSymbol

  • When I attempt to power on the phone wether it is plugged in or not (or hit any other hardware buttons), the symbol is the same on the screen, but with an added lightning bolt on the top. Perhaps this is to say that the battery needs charged?

  • I thought that there may be an issue with residual capacitance that sometimes builds up within devices so I placed the phone in a hobby vice that I have (really light pressure I usually use it for PC board work) to press all hardware buttons for about 24 hours. This seemed to have no affect whatsoever, whether positive or negative, to the phone.

I think that my next course of action would be to do the following.

  1. Take the battery out of the phone.
  2. Test the battery itself. Given that it has been plugged in the whole time, there should be close to the rated voltage on it.
  3. Assuming the battery is bad, order a new one using the model number on the battery since I have been having trouble finding a battery.

It may be a while before I have the time to do this, but when Iget done with that, I’ll post an update.

Even if I don’t fix the phone, it’ll be nice to have some experience working on this without the possibily of messing it up any more than it is.

The Symbol says that an empty battery is charged. But this obviously is not the case. It still could be the USB port or the battery. Maybe changing both once the phone case is open might be a good idea.

@GMRider I am just speculating and speaking from my experience.

I had an issue on my Redmi Note 4 when the phone decided to behave in a similar manner as yours and randomly shutdown or reboot some time back. I thought my device had some major damage. I only had to take the phone apart and clean the connector attaching the battery to the main board to fix it. It has been going strong ever since, until I dropped it recently and broke the screen leading to a partially damaged touch screen digitiser.

That’s IT! Finally had some time to try this.

I got the back cover off (a heat gun on low and a guitar pick), and all I did was unplug the battery and plug it back in.

I then plugged in a USB-C cable and the standard Sailfish OS charge screen (when the device is off) came up instead of the dead battery symbol that I drew in XPaint!

I have been able to power off and restart the phone several times with no issues! Other than the back cover off, the phone seems fine.

The only oddity that I see is that the charge LED is solid white when the screen is off, even when not charging.

I haven’t cleaned the battery contact yet. Just unplugged it and re-plugged it.

What do you recommend to clean it? I tiny shot of contact cleaner?

I’m more of an old-school through hole guy when it comes to electronics. Not used to stuff like this and want to make sure I don’t mess up the phone.

Looks like I just need to clean it, and find the adhesives to put it back together and I’ll be back in business.

Thanks to everyone that has tried to help me with this.

1 Like

One more thing that I failed to mention before, for about a year, something has been rattling around in the phone.

When I took the cover off, two small silver screws were loose and came out.

Not sure where they go exactly, I’ll investigate when I put it back together.

Not sure if this had anything to do with my issue or not since the phone seems to work after unplugging and replugging the battery.

Great to read that you might have solved the issue completely.

I used a fine brush and some iso-propyl alcohol if I remember it right. It might, as well, have been a loose connector only, and not any debri on the contacts being the real reason.