[BUG][4.2.0.19] Cannot import calendar entries via ics-file

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.2.0.19
HARDWARE (XA2, X10, X10 II, …): Xperia 10 II
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

I cannot import ics-files (and thus calendar enties) anymore. I tried with files that worked fine prior to updtaing to 4.2.0.19 and I tried with a 3.4.0.24 device (XZ3) as well. Importing the file with 3.4.0.24 worked while i did not work with 4.2.0.19 (but I know it was wirking under 4.1.0)

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Open ics file with file browser found under settings → memory
  2. Calendar app opens, saying “calendar file could not be imported”

EXPECTED RESULT:

Calendar entries in file should be imported (as it used to be)

ACTUAL RESULT:

calendar file cannot be imported - and thus no calendar entries

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

I wonder whether this affects restoring calendar entries from a back-up since all calendar entries in the back-up file are stored in the ics format.

Can you give a bit more details ?

  • importing through the filemanager I guess by typing on a .ics file,
  • can you provide a .ics example (after removing personal data).

I can try to reproduce.

1 Like

Thank you, Damien. I just send you a message with the .ics file text of a test calendar entry. I could send you the .ics file but I do not know how.

Thank you, I got it. I’ll test it later this afternoon.

1 Like

Great, thanks a lot!

Depending where the ICS file is located, this may be an issue with the application isolation. Sailjail is only authorizing the following directories:

  • $HOME/Documents and $HOME/android_storage/Documents,
  • $HOME/Downloads and $HOME/android_storage/Downloads,
  • $HOME/Music, $HOME/Playlists, $HOME/android_storage/Music and $HOME/android_storage/Podcasts,
  • $HOME/Pictures, $HOME/Images, $HOME/android_storage/Pictures and $HOME/android_storage/DCIM,
  • $HOME/Public,
  • $HOME/Videos and $HOME/android_storage/Movies.

Everything out of these directories will raise an error in the importation dialog.

1 Like

You may be right - thank you for reminding me on Sailjail. I will copy the file to another directory and see what happens. I guess you just pinpointed the problem and found the solution. I will tell you

Thank you - you were right, it isn’t the file but the directory that caused the problem. I just copied the file to $HOME/Downloads and import works as usual.

I have to keep that in mind.

I’ve only a slight idea on how isolation is working, but it’s a bit boring that one cannot access files from an action that was started by the user. Besides, the error should pin point itself to the root of the problem, so one can move the file to an allowed location. I may look into this.

1 Like