Bluetooth: Car kit unable to detect incoming calls even though phone is paired

REPRODUCIBILITY (% or how often): 100% (every time)
BUILD ID: 3.3.0.16 (Rokua)
HARDWARE (Jolla1, Tablet, XA2,…): Sony Xperia 10
UI LANGUAGE:Finnish
REGRESSION: (compared to previous public release: Yes, No, ?): No
CAR: Citroën C4 Cactus 2019

DESCRIPTION:

When I pair my phone with the car, it works partially. I can see recent calls, can browse contacts. I can use car to make phone calls, either by using the touchscreen (typing number, choosing one of the recent calls or browsing contacts) or using voice recognition (e.g. call Sofia). My phone and the car pair themselves without a problem.

Receiving phone calls via car does not work. The phone rings, car is silent. If I answer the call via phone, the audio is routed to the car, but nothing can be heard. So I need to disconnect the hands free (via the displays) and use the phone normally.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Phone is paired to with the car succesfully.
  2. There’s an incoming phone call.

EXPECTED RESULT:

Car kit will play alarm and the car’s display shows incoming call which also pauses the radio/audio if one is in use. And I can answer the call via car kit (touchscreen or voice command). Even answering the call using the phone should cause voice to be routed to the car and car kit should work as if the call would have been answered via it.

ACTUAL RESULT:

Only phone rings. Car kit is apparently not aware of incoming call. Radio/other audio is not muted, unable to answer the call via car kit. Answering via phone does not produce sound from car kit.

ADDITIONAL INFORMATION:

I’m pretty sure this worked on original Jolla phone which was on older firmware version, but as I switched to Xperia 10, I am not able to try it out.