Baikal DAV + SFOS: Calendar Doubles and no Items Visible


I am using SFOS 3.3 and latest Baikal DAV Client 0.7.1. I cannot unfortunately get the calendar working. Regardless of which Baikal version (0.6.1, 0.4.6, 0.3.5) or URL (/cal.php, /dav.php, user/default etc.) I tried, the result is always the same:

  • SFOS apparently recognizes there is a calendar when creating a new dav account, adding the calendar with the correct name
  • SFOS retrieves card data flawlessly
  • when in calendar app however, I cannot see any calendar items (also tried sync, reboot etc.)
  • even more annoying, SFOS creates a new instance of the very same calendar in the “manage calendars” section with EVERY sync
  • when adding a new calendar item it won’t process (will not be visible somewhere else)

So I can see lots of instances of the calendar with the right name in SOFS, but no actual calendar items.

Ideas anyone how to solve this issue?

Thanks in advance for any advice!



I am using Baikal as well (version 0.7.1), and works perfectly with CalDAV (and also CardDAV).

The URL I’m using is:



thanks! Tried it, still the same odd behaviour…may I ask, are you using an email as username? e.g.: I am suspecting the @ or . could create issues here…

…okay, that IS apparently the issue, just added a new one word ID user to Baikal and it works…either SFOS or Baikal cannot resolve special characters like “.” or “@” properly…

This bug has been fixed and should not be present in 3.4.0.x anymore, see:

1 Like

I am not, but i saw you found the root cause :slight_smile: