Backup to SD Memory problem

I have a 250GB SD card installed. It’s encrypted and I wanted to backup to this card. The graphic in Storage shows that it is full, but I have never used it. When I go to Backup, I press “Mount”. Most of the time it does not work. When it does work, it asks for a password. After the password is entered, the swirling graphic continues without stopping. I tried to erase the card and start over using Utilities, but still no success. Does anyone have advice? Thanks.

Update: I reformatted and changed the name of the SD Card. It shows “0 B” Used and “0 B” Free in Storage. In Backup, it still will not mount.

Did you try to reformat in a pc?

I formatted the SD Card in a Linux PC using Gnome Disks. I then placed the SD Card back into the Sony Xperia XA2 and let Sailfish format it there. I am having the same problems as described before. It does not ask for password anymore. It is unresponsive when I tap on “Mount”.

I am sorry. Linux and gparted did the job for me. I have no idea what went wrong.

I’ll look into getting another SD Card to try.