[] [XA2 Plus Dual SIM H4413] SD-card not accessible to Camera app

REPRODUCIBILITY (% or how often):100%
BUILD ID = OS VERSION (Settings > About product): Vanha Rauma, LUKS1
HARDWARE (XA2, X10, X10 II, …): XA2 Plus H4413, firmware driver version:
REGRESSION: (compared to previous public release: Yes, No, ?): [Previous Sailfish 4.x.x.xx OS public releases] No


Recently introduced Fire-/Sailjail feature leaved a permission bug to external SD-card storage.


Declaration: no Vanilla- / Stock OS environment.
In Settings app:
a) 3-party software enabled
b) Developer mode enabled
c) Openrepos repositories in use
d) Chum OBS repositories in use
e) Patchmanager in use
f) unencrypted SD-card mounted and accessible from OS file browser


  1. healty 0755 defaultuser permissions to /run/media/defaultuser/ && /media/sdcard
  2. switch in Camera settings between (back and forth) device internal- and SD-card storage
  3. take a photo or video with each Camera savepath setting
  4. image or video is saved to internal storage when SD-card storage is set to active


Image or video is saved to SD-card, when set in Settings->Applications->Camera.


Image or video is saved to device storage, when SD-card storage path is set.


Internal- and USB-OTG storage path works and allowed to Camera app.
SD-card is the only storage path, which is blocked to the Camera app.

Can’t reproduce it on my XA2+ Dual Sim (H4413)

1 Like

Okay, thanks for the info.
I maybe then have conflicting packages installed.
Or something resulted a bad configuration from 4.3 to 4.4 OTA update.

Similar issue with Xperia X: pics saved on device only. If Camera is set to save on SDcard, pics are not saved at all.

EDIT: issue solved after Pictures/Camera folder on SDcard ‘chowned’ to nemo and ‘chmodded’ to 777. Android apps still can’t see the pictures.

@DarkWhite @Objectifnul Are you still facing this bug?

@pherjung Yes I’m still having this issue. In my XA2 Plus Dual Sim 4.4 system, this bug is a system wide: camera, backup tool and some SF apps (filecat). Backup complains write error to SD-card. However I can access pictures from Gallery. Odd. I think I found a lead to this mystery. When I examined fstab, I noticed a UUID-mismatch between fstab records and actually mount path UUID-name. Could that be the culprit? Is it possible 4.4 upgrade can mess up SD-card UUID-number?

My SD-card filesystem might be unsupported. I have been using OpenRepos olebr exfat library. Card reports itself as a ext4 partition, but filesystem as a exfat. This might be the ‘user error’ conflict of what worked before Vanha Rauma.

df -h (edited):
Disk /dev/mmcblk1: 58,4 GiB
Disklabel type: dos
Disk identifier: 0x00000000
/mmcblk1p1 HPFS/NTFS/exFAT

fdisk -l:
/dev/mmcblk1p1: UUID=“5cf517b3-b958-4436-8c8c-081800346c7d” TYPE=“ext4”

Backup, format and encrypt.