[4.2.0.19] Xperia 10 II doesn't record sound after making a call

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.2.0.19
HARDWARE (XA2, X10, X10 II, …): Xperia 10 II
UI LANGUAGE: Spanish
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

AudioRecorder app (or others apps that record audio) doesn’t record sound and it records a flat line. It always happens after making a call.

If I reboot my phone, it works again, but it’s very annoying to boot my phone every time I make a call or when I want to record audio.

I’ve read this thread: [4.1.0.23] New audio recorder: flat line
But in my case, Documents/Recordings directory is created

PRECONDITIONS:

Testing with AudioRecorder:
Install AudioRecorder, open it and accept permissions.
Reboot phone

STEPS TO REPRODUCE:

  1. Open AudioRecorder and check it works fine (it records sound). Close it
  2. Make a call
  3. Open AudioRecorder again. It stop working because it doesn’t record sound

EXPECTED RESULT:

AudioRecorder records sound

ACTUAL RESULT:

AudioRecorder doesn’t record sound

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

2 Likes

Same device, same OS version, but I have no problem making recordings. I will try it randomly to see if it ceases recording, but so far, it does what it should.

2 Likes

Thanks for your answer!!
I guess a process must crash for some reason (maybe ¿pulseaudio?)

I’ve noticed it because some voice messages I send from fernschreiber don’t sound, but none of apps that record sound works in that moment. So I have to reboot my phone If I want to send voice messages or record audios, it’s very annoying.

I’ve noticed this once so far and also solved it by rebooting. It didn’t happen before 4.2. It was pretty annoying, because I’d just recorded a video and afterwards noticed there was no sound on it at all.

1 Like

I’ve been doing some testings and it always fails after making a call. I.e., after making a call I can’t record sound with any audio recorder.
I’ve edited first post.

2 Likes

It doesn’t work on 4.2.0.21 version. On the other hand, I can confirm that it doesn’t happen on XA2

2 Likes