[3.4.0 onwards] Bluetooth turning on doesn't work

Could someone at Jolla add this bluetooth reset to the Jolla Utilities? That would be super useful.

And an Android on/off switch for the events view? Thank you ;-p


I think the best way is to make sure it works the right way without ever having the need to restart the service in the first place.

Yes I have this problem addition to loosing wlan and mobile network regularly. Irritating problem when you rely being reachable but the phone has dropped silently out of all connections.

1 Like

Are there users with an Xperia 10 experiencing the same issue or is it restricted to X, XA2 ?

I may have a similar problem with Xperia 10. I have just discovered this thread and actually thought my issue was linked to the “Situations” application.
During the night, the situations application turns the ‘flight mode on’ on my phone, and in the morning, maybe in 20-25% of cases, when the application puts the flight mode off, bluetooth is not back and is impossible to turn on. I am using the application for ages and this is quite recent (some months…) even though I cannot remember when and which SFOS or Situations update triggered it.

When I have the problem, I usually deactivate the ‘situations’ application and reboot. Then I reactivate “situations” and all is fine for some days. The issue never happens during the day even though I am usually connected to a pebble watch all day long.
I can try to restart bluetooth services next time it happens to see if it solves my issue.

I’ve been experiencing this problem lately on an Xperia X with Sailfish 4.0.1.

In my case, I can turn BT on, but only once. When I turn it off I get the following relevant lines in my logs:

mar 19 19:29:48 SailfishX bluetooth_rfkill_event[737]: main(bluetooth_rfkill_event.c:1259): BT power driver blocked
mar 19 19:29:50 SailfishX bluetooth_rfkill_event[737]: free_hci(bluetooth_rfkill_event.c:906): killing hciattach failed
mar 19 19:29:50 SailfishX bluetooth_rfkill_event[737]: main(bluetooth_rfkill_event.c:1261): BT disabled

The icon shows BT as disabled but the hciattach proccess is still alive…preventing every new attempt to turn BT on again from working.
I hope this is fixed in the next upstream release.
Best regards.


The solutions using the command line above work to restart the bluetooth and make it work again. There is also this thread that has a solution using the sailfish utilities app Add Bluetooth reset/restart to the Sailfish Utilities app

1 Like

…does not work for me and my XperiaX in this case.

Another observation: After turning on BT and searching for devices it shows my Sennheiser MB Pro 2 in the list of known devices. But the visibility of the Xperia is OFF. A known device should connect anyway but it doesn’t. I cannot switch the visibility on – not even for 15 minutes. Every now and then when I switch on BT the visibility is ON. Then the headset connects immediately and works without a problem – until it disconnects once, then it cannot reconnect.

The BT on my phone, Xperia X, is always set on Visibility Off and the headset always connects automatically. But the phone is on 4.0 and not 3.4 as the OP title. It might make a difference.

Same here … a little frustrating

Yeah, and it’s even more frustrating when:

  • This has been reported during the early access: [release notes] Koli 4.0.1. Isn’t early access especially for that? Isn’t Bluetooth an important feature?
  • This happens on a “major” upgrade. I’m ok for some marketing, but not with such regression on core smartphone features!
  • Jolla doesn’t provide a hotfix and don’t care about letting such core features broken for months :tired_face:

So we now need to reboot (or find the good command lines) each time we need to use Bluetooth or record a call, a great way to enter the 4th generation :frowning_face:


I noticed that to on my only a few days old flash of SFX 4.0.1 on Xperia 10. I tried restart first and it worked.

I just had to do the restart network in SF Utilities twice to get my BT working again.

Then you are the lucky one ;-).
BT doesn’t worke here anymore right now.

Not even after restarting the phone? If it does not work anymore I would try reverting to Android and trying there.

No, but there were several reboots.
I will wait for the next update first, maybe that will bring an improvement in this matter ;-). I don’t have the time to always switch between SFOS and Android when there is a problem. This is also one of those pains with SFOS ;-).
I am currently not thinking of a hardware defect, as it worked a few times after the last update.
We will see…

Good news guys! For some reason my XPERIA X now finds and connects my BT headphones at least after almost every reboot. I have no idea why, though! If I restart it once in the morning the headphones work – at least as long as I do not disconnect them. I always knew that these devices have their own souls :upside_down_face::wink:. Let’s keep the fingers crossed that it works like this until the next update will fix it altogether.

1 Like

I made the following observation on Koli (, Xperia X):

Starting point:
Bluetooth turns on normally on a freshly booted phone.
Connecting to a Bluetooth device works, automatically as well.

  1. Turn BT off
  2. Turn BT on again - takes longer than usual (a few seconds)
  3. Connecting is not working anymore
  4. Turn BT off
  5. Try turning it on: Won’t work. Top Menu button stays gray, radio button in setting keeps blinking.
  6. Reboot the phone: Bluetooth is turned on automatically

The cycle repeats…

Does anyone have a hint on how to collect the right logs?

@jovirkku: I’m being blunt and ping you directly. Could you comment on this?
Can we do anything to help debugging?


I experience exactly the same pattern! Thank you for sharing. The only thing that miraculously changed is that it works now as if my XPERIA X had reprogrammed itself. In the beginning it would only connect occasionally. Since a few weeks it suddenly connects every day and I only have to restart it if I disconnect my headset.

I can testify that I have the exact same bug ! (on the same phone)
My current solution remains rebooting the phone every time… I tried this patch but it did not change anything…