[] Jolla1 black screen after update

REPRODUCIBILITY (% or how often): 100
BUILD ID = OS VERSION (Settings > About product): updating to 3.4.0 from 3.2.0
HARDWARE (Jolla1, Tablet, XA2,…): Jolla1
REGRESSION: (compared to previous public release: Yes, No, ?):


I tried updating the OS to Pallas-Yllästunturi 3.4.0. The updated downloaded normally, I selected install update, device turned off, started updating, I believe it finished updating, then screen turned black, with white LED showing. Turning the phone on or off didn’t work at first, then holding the power button turned LED red, but nothing else, the LED was still showing red after several minuted. Pressing power button again, turned the LED white, but again nothing else happened. No sound/vibration from device, screen completely black the entire time.

From recovery mode I then did a factory reset. Reverted back to Sailfish OS 1.0, I had a few issues with updating early versions, where I’d install update, but phone would boot into the old OS version instead, updated again and it worked. I successfully updated all the way to 3.2. I did not install a single app from Jolla store or anywhere else in the process. I did not log in to any account, except for Jolla account. The update to 3.4 is now in same state, the Sailfish logo appeared before/during the update, and now the screen has been black for a few hours. The wifi-router shows the phone connected, but I can not ping it.
I turned the phone off, it turned off, although the red led was shining for quite a while. Turning the phone back on, seems to turn it on, Jolla logo appears, white led turns on, then the screen turns black and stays black. The indicator white led keeps shining all the time.


Jolla 1 phone with sfos 3.2 installed. No additional apps installed.


  1. Factory reset Jolla 1
  2. Update to sfos 3.2
  3. Attempt to update to sfos 3.4


Phone turning on/off, update failing and reverting to 3.2 at worst.


Screen black, phone appears to be on, but is unusable.


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Welcome to the forum. I would suggest installing SFOS Upgrade from Openrepos which clears things up as you go along when carrying out successive updates:

sfos-upgrade: good suggestion, indeed.

But a bug this is, a phone not updating itself from step zero to last.

I would guess you need to do a btrfs balancing after all those updates and big data downloads and chunks used?

What about another try and see here?

sfos-upgrade does also some btrfs checking…