[3.4.0.24] Email subfolders are not updated (new mail not detected)

REPRODUCIBILITY (% or how often): always
BUILD ID = OS VERSION (Settings > About product): 3.4.0.24
HARDWARE (Jolla1, Tablet, XA2,…): Xperia 10
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?): no

DESCRIPTION:

3.4 introduced subfolders. So when my mail provider offers subfolders the Sailfish Mail Client recognizes them. So far this works.
However when the mail is updated automatically, subfolders don’t get updated.

PRECONDITIONS:

Automatic updates of email accounts is enabled. Exchange protocol is set to IMAP (didn’t test POP3).

STEPS TO REPRODUCE:

  1. send test mail to subfolder (e.g. by filter rule at mail provider)
  2. let Sailfish Mail Client update
  3. new mail in subfolder is not shown in the Sailfish notifications nor in the welcome screen/account of the mail client.
  4. go to the respective subfolder in Sailfish Mail Client, now the subfolder updates and new mail is detected.

EXPECTED RESULT:

Mail Client updates all subfolders along with the standard update cycle.

ACTUAL RESULT:

subfolders are not updated unless the folder is entered by the user.

Did select all folders to be updated in the email account settings? I think only the inbox is updated by default.

Thanks for the hint!

I see no such setting?

Only the current folder gets updated, which is sensible as it could potentially cause unwanted memory drain.

You will find the setting in
Settings > Accounts > ‘Select your E-Mail account’. :slightly_smiling_face:

1 Like

Silly me. I was looking in Settings > Apps > Email. It’s been years since I made the account so I forgot it.

Sorry @spark, I gave you wrong info. Still it’s good advice to sync only the needed folders for the same reason.

Btw:

3.4 introduced subfolders.

AFAIRC it’s been there since day one?